Commit 01fcae18 authored by Pavel Mashliakovskiy's avatar Pavel Mashliakovskiy 🤹🏻
Browse files

Publish

 - autotest@5.20.7
 - benchmarks@5.1.6
 - docs-adminui@0.0.67
 - node@1.0.164
 - @unitybase/adminui-pub@5.20.5
 - @unitybase/adminui-reg@5.20.5
 - @unitybase/adminui-vue@5.20.5
 - @unitybase/base@5.20.2
 - @unitybase/blob-stores@5.20.5
 - @unitybase/cdn@5.20.5
 - @unitybase/cs-shared@5.6.2
 - @unitybase/dml-generator@5.20.2
 - @unitybase/hmr@1.1.2
 - @unitybase/http-proxy@5.20.5
 - @unitybase/openid-connect@5.20.5
 - @unitybase/org@5.20.5
 - @unitybase/ub-pub@5.9.2
 - @unitybase/ub@5.21.1
 - @unitybase/uba@5.20.5
 - @unitybase/ubcli@5.21.0
 - @unitybase/ubm@5.20.5
 - @unitybase/ubq@5.20.5
 - @unitybase/ubs@5.20.5
 - @unitybase/udisk@5.20.5
 - @unitybase/xlsx@5.20.2
parent bb578aec
Pipeline #28282 passed with stage
in 1 minute and 25 seconds
{
"name": "autotest",
"version": "5.20.6",
"version": "5.20.7",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "autotest",
"version": "5.20.6",
"version": "5.20.7",
"description": "Autotest for UnityBase",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/apps/autotest",
"private": true,
......@@ -22,32 +22,32 @@
},
"dependencies": {
"@popperjs/core": "^2.5.3",
"@unitybase/adminui-pub": "^5.20.4",
"@unitybase/adminui-reg": "^5.20.4",
"@unitybase/adminui-vue": "^5.20.4",
"@unitybase/base": "^5.20.1",
"@unitybase/blob-stores": "^5.20.4",
"@unitybase/cdn": "^5.20.4",
"@unitybase/adminui-pub": "^5.20.5",
"@unitybase/adminui-reg": "^5.20.5",
"@unitybase/adminui-vue": "^5.20.5",
"@unitybase/base": "^5.20.2",
"@unitybase/blob-stores": "^5.20.5",
"@unitybase/cdn": "^5.20.5",
"@unitybase/codemirror-full": "^1.3.0",
"@unitybase/cryptojs": "^1.0.14",
"@unitybase/cs-shared": "^5.6.1",
"@unitybase/dml-generator": "^5.20.1",
"@unitybase/http-proxy": "^5.20.4",
"@unitybase/cs-shared": "^5.6.2",
"@unitybase/dml-generator": "^5.20.2",
"@unitybase/http-proxy": "^5.20.5",
"@unitybase/mailer": "^5.5.4",
"@unitybase/openid-connect": "^5.20.4",
"@unitybase/org": "^5.20.4",
"@unitybase/openid-connect": "^5.20.5",
"@unitybase/org": "^5.20.5",
"@unitybase/pdf": "^5.1.0",
"@unitybase/systemjs-plugin-vue-ub": "^1.4.0",
"@unitybase/ub": "^5.21.0",
"@unitybase/ub": "^5.21.1",
"@unitybase/ub-migrate": "^1.17.1",
"@unitybase/ub-pub": "^5.9.1",
"@unitybase/uba": "^5.20.4",
"@unitybase/ubcli": "^5.20.5",
"@unitybase/ubm": "^5.20.4",
"@unitybase/ubq": "^5.20.4",
"@unitybase/ubs": "^5.20.4",
"@unitybase/udisk": "^5.20.4",
"@unitybase/xlsx": "^5.20.1",
"@unitybase/ub-pub": "^5.9.2",
"@unitybase/uba": "^5.20.5",
"@unitybase/ubcli": "^5.21.0",
"@unitybase/ubm": "^5.20.5",
"@unitybase/ubq": "^5.20.5",
"@unitybase/ubs": "^5.20.5",
"@unitybase/udisk": "^5.20.5",
"@unitybase/xlsx": "^5.20.2",
"asn1js": "^2.0.19",
"codemirror": "^5.58.1",
"element-ui": "^2.13.0",
......@@ -74,7 +74,7 @@
"vuex": "^3.1.2"
},
"devDependencies": {
"@unitybase/hmr": "^1.1.1",
"@unitybase/hmr": "^1.1.2",
"@unitybase/stubs": "^5.1.10"
},
"peerDependencies": {
......
{
"name": "benchmarks",
"version": "5.1.5",
"version": "5.1.6",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "benchmarks",
"version": "5.1.5",
"version": "5.1.6",
"description": "Benchmarks for UnityBase for a scenarios from the [TechEmpower Web Framework Benchmarks](https://www.techempower.com/benchmarks/).",
"main": "index.js",
"scripts": {
......@@ -20,15 +20,15 @@
},
"homepage": "https://github.com/UnityBaseJS/benchmarks#readme",
"dependencies": {
"@unitybase/base": "^5.20.1",
"@unitybase/cs-shared": "^5.6.1",
"@unitybase/dml-generator": "^5.20.1",
"@unitybase/ub": "^5.21.0",
"@unitybase/ub-pub": "^5.9.1",
"@unitybase/base": "^5.20.2",
"@unitybase/cs-shared": "^5.6.2",
"@unitybase/dml-generator": "^5.20.2",
"@unitybase/ub": "^5.21.1",
"@unitybase/ub-pub": "^5.9.2",
"mustache": "^3.0.1"
},
"devDependencies": {
"@unitybase/stubs": "^5.1.10",
"@unitybase/ubcli": "^5.20.5"
"@unitybase/ubcli": "^5.21.0"
}
}
{
"name": "docs-adminui",
"version": "0.0.66",
"version": "0.0.67",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "docs-adminui",
"version": "0.0.66",
"version": "0.0.67",
"description": "Adminui components docs",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/apps/docs-adminui",
"private": true,
......@@ -18,16 +18,16 @@
"dev": "gnome-terminal -x npm run ubapp; npm run watch"
},
"dependencies": {
"@unitybase/adminui-pub": "^5.20.4",
"@unitybase/adminui-reg": "^5.20.4",
"@unitybase/adminui-vue": "^5.20.4",
"@unitybase/cdn": "^5.20.4",
"@unitybase/cs-shared": "^5.6.1",
"@unitybase/ub": "^5.21.0",
"@unitybase/ub-pub": "^5.9.1",
"@unitybase/uba": "^5.20.4",
"@unitybase/ubm": "^5.20.4",
"@unitybase/ubs": "^5.20.4",
"@unitybase/adminui-pub": "^5.20.5",
"@unitybase/adminui-reg": "^5.20.5",
"@unitybase/adminui-vue": "^5.20.5",
"@unitybase/cdn": "^5.20.5",
"@unitybase/cs-shared": "^5.6.2",
"@unitybase/ub": "^5.21.1",
"@unitybase/ub-pub": "^5.9.2",
"@unitybase/uba": "^5.20.5",
"@unitybase/ubm": "^5.20.5",
"@unitybase/ubs": "^5.20.5",
"file-saver": "^1.3.3",
"jdenticon": "^2.1.1",
"js-beautify": "^1.11.0",
......@@ -44,7 +44,7 @@
},
"devDependencies": {
"@unitybase/ub-migrate": "^1.19.0",
"@unitybase/ubcli": "^5.20.5",
"@unitybase/ubcli": "^5.21.0",
"babel-loader": "^8.2.2",
"css-loader": "^5.2.0",
"file-loader": "^6.2.0",
......
{
"name": "node",
"version": "1.0.163",
"version": "1.0.164",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "node",
"version": "1.0.163",
"version": "1.0.164",
"description": "Call UnityBase methods from node.js",
"main": "ub_from_node.js",
"private": true,
......@@ -10,7 +10,7 @@
"author": "",
"license": "ISC",
"dependencies": {
"@unitybase/ub-pub": "^5.9.1",
"@unitybase/ub-pub": "^5.9.2",
"xhr2": "^0.1.4"
}
}
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.20.5] - 2021-04-13
## [5.20.4] - 2021-04-02
## [5.20.3] - 2021-04-01
## [5.20.2] - 2021-03-30
......
{
"name": "@unitybase/adminui-pub",
"version": "5.20.4",
"version": "5.20.5",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-pub",
"version": "5.20.4",
"version": "5.20.5",
"description": "UnityBase admin UI",
"main": "adminui.js",
"browser": {
......@@ -37,10 +37,10 @@
},
"dependencies": {
"@unitybase/codemirror-full": "^1.3.0",
"@unitybase/cs-shared": "^5.6.1",
"@unitybase/ub-pub": "^5.9.1",
"@unitybase/ubm": "^5.20.4",
"@unitybase/xlsx": "^5.20.1",
"@unitybase/cs-shared": "^5.6.2",
"@unitybase/ub-pub": "^5.9.2",
"@unitybase/ubm": "^5.20.5",
"@unitybase/xlsx": "^5.20.2",
"codemirror": "^5.44.0",
"file-saver": "^1.3.3",
"js-beautify": "^1.6.12",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.20.5] - 2021-04-13
## [5.20.4] - 2021-04-02
## [5.20.3] - 2021-04-01
## [5.20.2] - 2021-03-30
......
{
"name": "@unitybase/adminui-reg",
"version": "5.20.4",
"version": "5.20.5",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-reg",
"version": "5.20.4",
"version": "5.20.5",
"description": "UnityBase admin UI (server part)",
"main": "index.html.js",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/adminui-reg",
......@@ -20,9 +20,9 @@
"registry": "https://registry.unitybase.info"
},
"dependencies": {
"@unitybase/adminui-pub": "^5.20.4",
"@unitybase/base": "^5.20.1",
"@unitybase/ub": "^5.21.0",
"@unitybase/adminui-pub": "^5.20.5",
"@unitybase/base": "^5.20.2",
"@unitybase/ub": "^5.21.1",
"mustache": "^3.0.1"
},
"devDependencies": {
......
......@@ -5,6 +5,17 @@ The format is based on [Keep a Changelog](http://keepachangelog.com/)
and this project adheres to [Semantic Versioning](http://semver.org/).
## [Unreleased]
### Added
### Changed
### Deprecated
### Removed
### Fixed
## [5.20.5] - 2021-04-13
### Added
- `UFormRow`: new prop `readonly`; if `true` - show a small lock symbol after label
- `UAutoField`: in case attribute is `readOnly` in meta file - render a small lock symbol after label;
......@@ -65,10 +76,6 @@ export default {
- `USelectEntity`: use a UDropdown instead of ElDropdown for actions popup; dropdown animation (transition) is removed
- `USelectEntity`: added background color and border to dropdown block
### Deprecated
### Removed
### Fixed
- `USelectEntity.buildShowDictionaryConfig`: fixed `select` button disabling if row is not selected yet.
A `disabled` property should be passed to `UButton` as a html-attribute.
......
{
"name": "@unitybase/adminui-vue",
"version": "5.20.4",
"version": "5.20.5",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-vue",
"version": "5.20.4",
"version": "5.20.5",
"description": "UnityBase admin UI extended with Vue + ElementUI",
"main": "adminui-vue.js",
"browser": {
......@@ -45,10 +45,10 @@
"dependencies": {
"@popperjs/core": "~2.8.6",
"@unitybase/codemirror-full": "^1.3.0",
"@unitybase/cs-shared": "^5.6.1",
"@unitybase/cs-shared": "^5.6.2",
"@unitybase/pdf": "^5.1.0",
"@unitybase/systemjs-plugin-vue-ub": "^1.4.0",
"@unitybase/ub-pub": "^5.9.1",
"@unitybase/ub-pub": "^5.9.2",
"element-ui": "2.13.0",
"jdenticon": "^2.1.1",
"js-beautify": "^1.11.0",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.20.2] - 2021-04-13
## [5.20.1] - 2021-04-02
## [5.20.0] - 2021-03-25
## [5.19.5] - 2021-03-23
......
{
"name": "@unitybase/base",
"version": "5.20.1",
"version": "5.20.2",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/base",
"version": "5.20.1",
"version": "5.20.2",
"description": "CLI classes for working with command line args, connecting to UnityBase server, bulk data loading",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/base",
"scripts": {
......@@ -14,7 +14,7 @@
"main": "base.js",
"dependencies": {
"@unitybase/cryptojs": "^1.0.14",
"@unitybase/cs-shared": "^5.6.1",
"@unitybase/cs-shared": "^5.6.2",
"lodash": "^4"
},
"devDependencies": {
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.20.5] - 2021-04-13
## [5.20.4] - 2021-04-02
## [5.20.3] - 2021-04-01
### Fixed
......
{
"name": "@unitybase/blob-stores",
"version": "5.20.4",
"version": "5.20.5",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/blob-stores",
"version": "5.20.4",
"version": "5.20.5",
"description": "BLOB stores implementation",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/blob-stores",
"config": {
......@@ -16,8 +16,8 @@
},
"main": "blobStores.js",
"dependencies": {
"@unitybase/base": "^5.20.1",
"@unitybase/cs-shared": "^5.6.1",
"@unitybase/base": "^5.20.2",
"@unitybase/cs-shared": "^5.6.2",
"lodash": "^4",
"mime-types": "^2.1.14"
},
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.20.5] - 2021-04-13
## [5.20.4] - 2021-04-02
## [5.20.3] - 2021-04-01
## [5.20.2] - 2021-03-30
......
{
"name": "@unitybase/cdn",
"version": "5.20.4",
"version": "5.20.5",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/cdn",
"version": "5.20.4",
"version": "5.20.5",
"description": "Set of dictionaries, common for most enterprise systems. For internal organization structure see @ubitybase/org module",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/cdn",
"config": {
......@@ -18,10 +18,10 @@
},
"main": "cdn.js",
"dependencies": {
"@unitybase/base": "^5.20.1",
"@unitybase/ub": "^5.21.0",
"@unitybase/uba": "^5.20.4",
"@unitybase/ubs": "^5.20.4",
"@unitybase/base": "^5.20.2",
"@unitybase/ub": "^5.21.1",
"@unitybase/uba": "^5.20.5",
"@unitybase/ubs": "^5.20.5",
"lodash": "^4"
},
"devDependencies": {
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.6.2] - 2021-04-13
## [5.6.1] - 2021-04-02
### Added
- new property `UBEntity.overriddenBy` - comma separated model names where entity is overridden
......
{
"name": "@unitybase/cs-shared",
"version": "5.6.1",
"version": "5.6.2",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/cs-shared",
"version": "5.6.1",
"version": "5.6.2",
"description": "Isomorphic classes shared between clients and server",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/cs-shared",
"scripts": {
......
{
"name": "@unitybase/dml-generator",
"version": "5.20.1",
"version": "5.20.2",
"description": "UnityBase DML Generator",
"scripts": {
"build:doc": "jsdoc -c ./jsdoc-conf.json --package ./package.json",
......@@ -12,7 +12,7 @@
},
"main": "index.js",
"dependencies": {
"@unitybase/base": "^5.20.1"
"@unitybase/base": "^5.20.2"
},
"devDependencies": {
"@unitybase/stubs": "^5.1.10",
......
{
"name": "@unitybase/hmr",
"version": "1.1.1",
"version": "1.1.2",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/hmr",
"version": "1.1.1",
"version": "1.1.2",
"description": "Module for watching changes in the public part of UnityBase and send notifications for UB adminUI in dev mode using web sockets",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/hmr",
"scripts": {
......@@ -15,7 +15,7 @@
},
"main": "server.js",
"dependencies": {
"@unitybase/ub-pub": "^5.9.1",
"@unitybase/ub-pub": "^5.9.2",
"chokidar": "^2.0.4",
"commander": "^2.16.0",
"ws": "^5.2.2",
......
{
"name": "@unitybase/http-proxy",
"version": "5.20.4",
"version": "5.20.5",
"description": "Proxy a HTTP(s) requests to enother HTTP server with optional UB authentication",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/http-proxy",
"public": true,
......@@ -9,12 +9,12 @@
},
"main": "HttpProxy.js",
"dependencies": {
"@unitybase/base": "^5.20.1"
"@unitybase/base": "^5.20.2"
},
"devDependencies": {
"@unitybase/base": "^5.0.26",
"@unitybase/stubs": "^5.1.10",
"@unitybase/ub": "^5.21.0"
"@unitybase/ub": "^5.21.1"
},
"keywords": [
"Proxy",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.20.5] - 2021-04-13
## [5.20.4] - 2021-04-02
## [5.20.3] - 2021-04-01
## [5.20.2] - 2021-03-30
......
{
"name": "@unitybase/openid-connect",
"version": "5.20.4",
"version": "5.20.5",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/openid-connect",
"version": "5.20.4",
"version": "5.20.5",
"description": "OpenID Connect authentication for UnityBase",
"keywords": [
"UB",
......@@ -23,8 +23,8 @@
"version": "update-changelog && git add CHANGELOG.md"
},
"dependencies": {
"@unitybase/base": "^5.20.1",
"@unitybase/ub": "^5.21.0",
"@unitybase/base": "^5.20.2",
"@unitybase/ub": "^5.21.1",
"btoa": "^1.1.2"
},
"devDependencies": {
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.20.5] - 2021-04-13
## [5.20.4] - 2021-04-02
## [5.20.3] - 2021-04-01
## [5.20.2] - 2021-03-30
......
{
"name": "@unitybase/org",
"version": "5.20.4",