Commit 9d9a9273 authored by Pavel Mashliakovskiy's avatar Pavel Mashliakovskiy 🤹🏻

Publish

 - autotest@5.0.243
 - benchmarks@5.0.180
 - @unitybase/adminui-pub@5.13.29
 - @unitybase/adminui-reg@5.4.29
 - @unitybase/cdn@5.4.25
 - @unitybase/http-proxy@5.1.24
 - @unitybase/openid-connect@5.1.24
 - @unitybase/org@5.3.25
 - @unitybase/ub@5.5.11
 - @unitybase/uba@5.4.24
 - @unitybase/ubcli@5.6.3
 - @unitybase/ubdev@0.0.115
 - @unitybase/ubm@5.4.7
 - @unitybase/ubq@5.3.24
 - @unitybase/ubs@5.4.14
 - @unitybase/udisk@5.0.137
parent c7ad4998
Pipeline #21772 skipped with stage
{
"name": "autotest",
"version": "5.0.242",
"version": "5.0.243",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "autotest",
"version": "5.0.242",
"version": "5.0.243",
"description": "Autotest for UnityBase",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/apps/autotest",
"private": true,
......@@ -16,29 +16,29 @@
},
"dependencies": {
"@popperjs/core": "^2.0.6",
"@unitybase/adminui-pub": "^5.13.28",
"@unitybase/adminui-reg": "^5.4.28",
"@unitybase/adminui-pub": "^5.13.29",
"@unitybase/adminui-reg": "^5.4.29",
"@unitybase/adminui-vue": "^1.12.2",
"@unitybase/base": "^5.2.14",
"@unitybase/cdn": "^5.4.24",
"@unitybase/cdn": "^5.4.25",
"@unitybase/codemirror-full": "^1.2.30",
"@unitybase/cryptojs": "^1.0.14",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/dml-generator": "^5.0.91",
"@unitybase/http-proxy": "^5.1.23",
"@unitybase/http-proxy": "^5.1.24",
"@unitybase/mailer": "^5.3.2",
"@unitybase/openid-connect": "^5.1.23",
"@unitybase/org": "^5.3.24",
"@unitybase/openid-connect": "^5.1.24",
"@unitybase/org": "^5.3.25",
"@unitybase/pdf": "^5.0.31",
"@unitybase/systemjs-plugin-vue-ub": "^1.3.9",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/uba": "^5.4.23",
"@unitybase/ubdev": "^0.0.114",
"@unitybase/ubm": "^5.4.6",
"@unitybase/ubq": "^5.3.23",
"@unitybase/ubs": "^5.4.13",
"@unitybase/udisk": "^5.0.136",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubdev": "^0.0.115",
"@unitybase/ubm": "^5.4.7",
"@unitybase/ubq": "^5.3.24",
"@unitybase/ubs": "^5.4.14",
"@unitybase/udisk": "^5.0.137",
"@unitybase/xlsx": "^5.1.33",
"asn1js": "^2.0.19",
"codemirror": "^5.44.0",
......@@ -68,7 +68,7 @@
"devDependencies": {
"@unitybase/hmr": "^1.0.107",
"@unitybase/stubs": "^5.1.1",
"@unitybase/ubcli": "^5.6.2"
"@unitybase/ubcli": "^5.6.3"
},
"peerDependencies": {
"testcafe": "^0.19.1"
......
{
"name": "benchmarks",
"version": "5.0.179",
"version": "5.0.180",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "benchmarks",
"version": "5.0.179",
"version": "5.0.180",
"description": "Benchmarks for UnityBase for a scenarios from the [TechEmpower Web Framework Benchmarks](https://www.techempower.com/benchmarks/).",
"main": "index.js",
"scripts": {
......@@ -23,12 +23,12 @@
"@unitybase/base": "^5.2.14",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/dml-generator": "^5.0.91",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"@unitybase/ub-pub": "^5.5.17",
"mustache": "^3.0.1"
},
"devDependencies": {
"@unitybase/stubs": "^5.1.1",
"@unitybase/ubcli": "^5.6.2"
"@unitybase/ubcli": "^5.6.3"
}
}
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.13.29] - 2020-07-28
## [5.13.28] - 2020-07-26
### Changed
- double-click on entity inside ER Diagram opens Vue base entity editor `ubm_form-entityEdit`.
......
{
"name": "@unitybase/adminui-pub",
"version": "5.13.28",
"version": "5.13.29",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-pub",
"version": "5.13.28",
"version": "5.13.29",
"description": "UnityBase admin UI",
"main": "adminui.js",
"browser": {
......@@ -39,7 +39,7 @@
"@unitybase/codemirror-full": "^1.2.30",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ubm": "^5.4.6",
"@unitybase/ubm": "^5.4.7",
"@unitybase/xlsx": "^5.1.33",
"codemirror": "^5.44.0",
"file-saver": "^1.3.3",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.4.29] - 2020-07-28
## [5.4.28] - 2020-07-26
## [5.4.27] - 2020-07-19
## [5.4.26] - 2020-07-16
......
{
"name": "@unitybase/adminui-reg",
"version": "5.4.28",
"version": "5.4.29",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-reg",
"version": "5.4.28",
"version": "5.4.29",
"description": "UnityBase admin UI (server part)",
"main": "index.html.js",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/adminui-reg",
......@@ -20,9 +20,9 @@
"registry": "https://registry.unitybase.info"
},
"dependencies": {
"@unitybase/adminui-pub": "^5.13.28",
"@unitybase/adminui-pub": "^5.13.29",
"@unitybase/base": "^5.2.14",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"mustache": "^3.0.1"
},
"devDependencies": {
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.4.25] - 2020-07-28
## [5.4.24] - 2020-07-26
## [5.4.23] - 2020-07-19
## [5.4.22] - 2020-07-16
......
{
"name": "@unitybase/cdn",
"version": "5.4.24",
"version": "5.4.25",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/cdn",
"version": "5.4.24",
"version": "5.4.25",
"description": "Set of dictionaries, common for most enterprise systems. For internal organization structure see @ubitybase/org module",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/cdn",
"config": {
......@@ -19,9 +19,9 @@
"main": "cdn.js",
"dependencies": {
"@unitybase/base": "^5.2.14",
"@unitybase/ub": "^5.5.10",
"@unitybase/uba": "^5.4.23",
"@unitybase/ubs": "^5.4.13",
"@unitybase/ub": "^5.5.11",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubs": "^5.4.14",
"lodash": "^4"
},
"devDependencies": {
......
{
"name": "@unitybase/http-proxy",
"version": "5.1.23",
"version": "5.1.24",
"description": "Proxy a HTTP(s) requests to enother HTTP server with optional UB authentication",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/http-proxy",
"public": true,
......@@ -14,7 +14,7 @@
"devDependencies": {
"@unitybase/base": "^5.0.26",
"@unitybase/stubs": "^5.1.1",
"@unitybase/ub": "^5.5.10"
"@unitybase/ub": "^5.5.11"
},
"keywords": [
"Proxy",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.1.24] - 2020-07-28
## [5.1.23] - 2020-07-26
## [5.1.22] - 2020-07-19
## [5.1.21] - 2020-07-16
......
{
"name": "@unitybase/openid-connect",
"version": "5.1.23",
"version": "5.1.24",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/openid-connect",
"version": "5.1.23",
"version": "5.1.24",
"description": "OpenID Connect authentication for UnityBase",
"keywords": [
"UB",
......@@ -24,7 +24,7 @@
},
"dependencies": {
"@unitybase/base": "^5.2.14",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"btoa": "^1.1.2"
},
"devDependencies": {
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.3.25] - 2020-07-28
## [5.3.24] - 2020-07-26
## [5.3.23] - 2020-07-19
## [5.3.22] - 2020-07-16
......
{
"name": "@unitybase/org",
"version": "5.3.24",
"version": "5.3.25",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/org",
"version": "5.3.24",
"version": "5.3.25",
"description": "Organisation structure",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/org",
"config": {
......@@ -19,10 +19,10 @@
"main": "org.js",
"dependencies": {
"@unitybase/base": "^5.2.14",
"@unitybase/cdn": "^5.4.24",
"@unitybase/ub": "^5.5.10",
"@unitybase/uba": "^5.4.23",
"@unitybase/ubs": "^5.4.13",
"@unitybase/cdn": "^5.4.25",
"@unitybase/ub": "^5.5.11",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubs": "^5.4.14",
"lodash": "^4"
},
"devDependencies": {
......
......@@ -13,6 +13,9 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Removed
### Fixed
## [5.5.11] - 2020-07-28
### Fixed
- show correct JS exception with trace in case domain transformation hook broke some entities
......
{
"name": "@unitybase/ub",
"version": "5.5.10",
"version": "5.5.11",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ub",
"version": "5.5.10",
"version": "5.5.11",
"description": "Build-in UnityBase model",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ub",
"config": {
......
......@@ -13,6 +13,9 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Removed
### Fixed
## [5.4.24] - 2020-07-28
### Fixed
- TOTP (Google Authenticator) One Time Password verification fixed to allow up to (inclusive) 90 second shift between the server and a caller.
Because of arithmetic mistake previous implementation validate correctly only up to (but not inclusive) +-30 second shift.
......
{
"name": "@unitybase/uba",
"version": "5.4.23",
"version": "5.4.24",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/uba",
"version": "5.4.23",
"version": "5.4.24",
"description": "UnityBase Administrative model. Define users, roles and permissions",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/uba",
"config": {
......@@ -19,7 +19,7 @@
"main": "uba.js",
"dependencies": {
"@unitybase/base": "^5.2.14",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"asn1js": "^2.0.19",
"pkijs": "^2.1.46"
},
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.6.3] - 2020-07-28
## [5.6.2] - 2020-07-26
## [5.6.1] - 2020-07-19
## [5.6.0] - 2020-07-16
......
{
"name": "@unitybase/ubcli",
"version": "5.6.2",
"version": "5.6.3",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubcli",
"version": "5.6.2",
"version": "5.6.3",
"description": "A simple CLI for scaffolding UnityBase projects",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubcli",
"config": {
......@@ -24,7 +24,7 @@
"@unitybase/base": "^5.2.14",
"@unitybase/compressors": "^5.1.33",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"lodash": "^4",
"mustache": "^3.0.1",
"ub-jsdoc": "^2.2.0"
......
{
"name": "@unitybase/ubdev",
"version": "0.0.114",
"version": "0.0.115",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubdev",
"version": "0.0.114",
"version": "0.0.115",
"description": "UnityBase developer tools",
"main": "ubdev.js",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubdev",
......@@ -23,7 +23,7 @@
"@unitybase/codemirror-full": "^1.2.30",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ubm": "^5.4.6"
"@unitybase/ubm": "^5.4.7"
},
"keywords": [
"UnityBase",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.4.7] - 2020-07-28
## [5.4.6] - 2020-07-26
## [5.4.5] - 2020-07-19
## [5.4.4] - 2020-07-16
......
{
"name": "@unitybase/ubm",
"version": "5.4.6",
"version": "5.4.7",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubm",
"version": "5.4.6",
"version": "5.4.7",
"description": "Set of entities for constructing a dynamically generated UnityBase UI. Enumerations, navigation desktops & shortcuts, forms, ER diagrams",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubm",
"config": {
......@@ -20,9 +20,9 @@
"dependencies": {
"@unitybase/base": "^5.2.14",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/ub": "^5.5.10",
"@unitybase/uba": "^5.4.23",
"@unitybase/ubs": "^5.4.13"
"@unitybase/ub": "^5.5.11",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubs": "^5.4.14"
},
"devDependencies": {
"@unitybase/stubs": "^5.1.1",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.3.24] - 2020-07-28
## [5.3.23] - 2020-07-26
## [5.3.22] - 2020-07-19
## [5.3.21] - 2020-07-16
......
{
"name": "@unitybase/ubq",
"version": "5.3.23",
"version": "5.3.24",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubq",
"version": "5.3.23",
"version": "5.3.24",
"description": "Asynchronous task queue persisted into database. Contains jobs for sending e-mail and updating FTS indexes",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubq",
"config": {
......@@ -21,8 +21,8 @@
"@unitybase/base": "^5.2.14",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/mailer": "^5.3.2",
"@unitybase/ub": "^5.5.10",
"@unitybase/uba": "^5.4.23",
"@unitybase/ub": "^5.5.11",
"@unitybase/uba": "^5.4.24",
"lodash": "^4",
"node-cron": "^1.1.2"
},
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.4.14] - 2020-07-28
## [5.4.13] - 2020-07-26
## [5.4.12] - 2020-07-19
## [5.4.11] - 2020-07-16
......
{
"name": "@unitybase/ubs",
"version": "5.4.13",
"version": "5.4.14",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubs",
"version": "5.4.13",
"version": "5.4.14",
"description": "Reports, User messages (notifications), Settings (aka about:config), Counters",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubs",
"config": {
......@@ -29,9 +29,9 @@
"@unitybase/base": "^5.2.14",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/pdf": "^5.0.31",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/uba": "^5.4.23",
"@unitybase/uba": "^5.4.24",
"@unitybase/xlsx": "^5.1.33",
"mime-types": "^2.1.14",
"mustache": "^3.0.1",
......
......@@ -6,8 +6,6 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
## [Unreleased]
### Added
- added new attributes `objectID` and `objectEntity` into `udisk_card` for further integration with the `Scriptum` system
- rewritten form opening by double click on file
### Changed
......@@ -17,6 +15,11 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.0.137] - 2020-07-28
### Added
- added new attributes `objectID` and `objectEntity` into `udisk_card` for further integration with the `Scriptum` system
- rewritten form opening by double click on file
## [5.0.136] - 2020-07-26
## [5.0.135] - 2020-07-19
## [5.0.134] - 2020-07-16
......
{
"name": "@unitybase/udisk",
"version": "5.0.136",
"version": "5.0.137",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/udisk",
"version": "5.0.136",
"version": "5.0.137",
"description": "UnityBase udisk",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/udisk",
"config": {
......@@ -20,7 +20,7 @@
"browser": "./public/udisk-public.js",
"dependencies": {
"@unitybase/base": "^5.2.14",
"@unitybase/ub": "^5.5.10",
"@unitybase/ub": "^5.5.11",
"lodash": "^4"
},
"devDependencies": {
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment