Commit f8bf4b9e authored by Pavel Mashliakovskiy's avatar Pavel Mashliakovskiy 🤹🏻

Publish

 - autotest@5.0.244
 - benchmarks@5.0.181
 - node@1.0.129
 - @unitybase/adminui-pub@5.13.30
 - @unitybase/adminui-reg@5.4.30
 - @unitybase/adminui-vue@1.12.3
 - @unitybase/cdn@5.4.26
 - @unitybase/hmr@1.0.108
 - @unitybase/org@5.3.26
 - @unitybase/ub-pub@5.5.18
 - @unitybase/ubdev@0.0.116
 - @unitybase/ubm@5.4.8
 - @unitybase/ubs@5.4.15
parent a3b3c025
Pipeline #21812 skipped with stage
{
"name": "autotest",
"version": "5.0.243",
"version": "5.0.244",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "autotest",
"version": "5.0.243",
"version": "5.0.244",
"description": "Autotest for UnityBase",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/apps/autotest",
"private": true,
......@@ -16,11 +16,11 @@
},
"dependencies": {
"@popperjs/core": "^2.0.6",
"@unitybase/adminui-pub": "^5.13.29",
"@unitybase/adminui-reg": "^5.4.29",
"@unitybase/adminui-vue": "^1.12.2",
"@unitybase/adminui-pub": "^5.13.30",
"@unitybase/adminui-reg": "^5.4.30",
"@unitybase/adminui-vue": "^1.12.3",
"@unitybase/base": "^5.2.14",
"@unitybase/cdn": "^5.4.25",
"@unitybase/cdn": "^5.4.26",
"@unitybase/codemirror-full": "^1.2.30",
"@unitybase/cryptojs": "^1.0.14",
"@unitybase/cs-shared": "^5.5.1",
......@@ -28,16 +28,16 @@
"@unitybase/http-proxy": "^5.1.24",
"@unitybase/mailer": "^5.3.2",
"@unitybase/openid-connect": "^5.1.24",
"@unitybase/org": "^5.3.25",
"@unitybase/org": "^5.3.26",
"@unitybase/pdf": "^5.0.31",
"@unitybase/systemjs-plugin-vue-ub": "^1.3.9",
"@unitybase/ub": "^5.5.11",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ub-pub": "^5.5.18",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubdev": "^0.0.115",
"@unitybase/ubm": "^5.4.7",
"@unitybase/ubdev": "^0.0.116",
"@unitybase/ubm": "^5.4.8",
"@unitybase/ubq": "^5.3.24",
"@unitybase/ubs": "^5.4.14",
"@unitybase/ubs": "^5.4.15",
"@unitybase/udisk": "^5.0.137",
"@unitybase/xlsx": "^5.1.33",
"asn1js": "^2.0.19",
......@@ -66,7 +66,7 @@
"vuex": "^3.1.2"
},
"devDependencies": {
"@unitybase/hmr": "^1.0.107",
"@unitybase/hmr": "^1.0.108",
"@unitybase/stubs": "^5.1.1",
"@unitybase/ubcli": "^5.6.3"
},
......
{
"name": "benchmarks",
"version": "5.0.180",
"version": "5.0.181",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "benchmarks",
"version": "5.0.180",
"version": "5.0.181",
"description": "Benchmarks for UnityBase for a scenarios from the [TechEmpower Web Framework Benchmarks](https://www.techempower.com/benchmarks/).",
"main": "index.js",
"scripts": {
......@@ -24,7 +24,7 @@
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/dml-generator": "^5.0.91",
"@unitybase/ub": "^5.5.11",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ub-pub": "^5.5.18",
"mustache": "^3.0.1"
},
"devDependencies": {
......
{
"name": "node",
"version": "1.0.128",
"version": "1.0.129",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "node",
"version": "1.0.128",
"version": "1.0.129",
"description": "Call UnityBase methods from node.js",
"main": "ub_from_node.js",
"private": true,
......@@ -10,7 +10,7 @@
"author": "",
"license": "ISC",
"dependencies": {
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ub-pub": "^5.5.18",
"xhr2": "^0.1.4"
}
}
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.13.30] - 2020-07-29
## [5.13.29] - 2020-07-28
## [5.13.28] - 2020-07-26
### Changed
......
{
"name": "@unitybase/adminui-pub",
"version": "5.13.29",
"version": "5.13.30",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-pub",
"version": "5.13.29",
"version": "5.13.30",
"description": "UnityBase admin UI",
"main": "adminui.js",
"browser": {
......@@ -38,8 +38,8 @@
"dependencies": {
"@unitybase/codemirror-full": "^1.2.30",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ubm": "^5.4.7",
"@unitybase/ub-pub": "^5.5.18",
"@unitybase/ubm": "^5.4.8",
"@unitybase/xlsx": "^5.1.33",
"codemirror": "^5.44.0",
"file-saver": "^1.3.3",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.4.30] - 2020-07-29
## [5.4.29] - 2020-07-28
## [5.4.28] - 2020-07-26
## [5.4.27] - 2020-07-19
......
{
"name": "@unitybase/adminui-reg",
"version": "5.4.29",
"version": "5.4.30",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-reg",
"version": "5.4.29",
"version": "5.4.30",
"description": "UnityBase admin UI (server part)",
"main": "index.html.js",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/adminui-reg",
......@@ -20,7 +20,7 @@
"registry": "https://registry.unitybase.info"
},
"dependencies": {
"@unitybase/adminui-pub": "^5.13.29",
"@unitybase/adminui-pub": "^5.13.30",
"@unitybase/base": "^5.2.14",
"@unitybase/ub": "^5.5.11",
"mustache": "^3.0.1"
......
......@@ -13,6 +13,9 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Removed
### Fixed
## [1.12.3] - 2020-07-29
### Fixed
- `UMasterDetailView`: added max detail height limit (75%). This fix issue when master table contains one or two rows and details expands on full view.
......
{
"name": "@unitybase/adminui-vue",
"version": "1.12.2",
"version": "1.12.3",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/adminui-vue",
"version": "1.12.2",
"version": "1.12.3",
"description": "UnityBase admin UI extended with Vue + ElementUI",
"main": "adminui-vue.js",
"browser": {
......@@ -48,7 +48,7 @@
"@unitybase/codemirror-full": "^1.2.30",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/systemjs-plugin-vue-ub": "^1.3.9",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ub-pub": "^5.5.18",
"element-ui": "2.13.0",
"jdenticon": "^2.1.1",
"js-beautify": "^1.11.0",
......
......@@ -13,6 +13,9 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Removed
### Fixed
## [5.4.26] - 2020-07-29
### Fixed
- `cdn_orgaccount`: allow `null` for `currencyID` attribute (milty-currency accounts)
- `cdn_orgaccount`: added default value for `acctype` = `CORR`
......
{
"name": "@unitybase/cdn",
"version": "5.4.25",
"version": "5.4.26",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/cdn",
"version": "5.4.25",
"version": "5.4.26",
"description": "Set of dictionaries, common for most enterprise systems. For internal organization structure see @ubitybase/org module",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/cdn",
"config": {
......@@ -21,7 +21,7 @@
"@unitybase/base": "^5.2.14",
"@unitybase/ub": "^5.5.11",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubs": "^5.4.14",
"@unitybase/ubs": "^5.4.15",
"lodash": "^4"
},
"devDependencies": {
......
{
"name": "@unitybase/hmr",
"version": "1.0.107",
"version": "1.0.108",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/hmr",
"version": "1.0.107",
"version": "1.0.108",
"description": "Module for watching changes in the public part of UnityBase and send notifications for UB adminUI in dev mode using web sockets",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/hmr",
"scripts": {
......@@ -15,7 +15,7 @@
},
"main": "server.js",
"dependencies": {
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ub-pub": "^5.5.18",
"chokidar": "^2.0.4",
"commander": "^2.16.0",
"ws": "^5.2.2",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.3.26] - 2020-07-29
## [5.3.25] - 2020-07-28
## [5.3.24] - 2020-07-26
## [5.3.23] - 2020-07-19
......
{
"name": "@unitybase/org",
"version": "5.3.25",
"version": "5.3.26",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/org",
"version": "5.3.25",
"version": "5.3.26",
"description": "Organisation structure",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/org",
"config": {
......@@ -19,10 +19,10 @@
"main": "org.js",
"dependencies": {
"@unitybase/base": "^5.2.14",
"@unitybase/cdn": "^5.4.25",
"@unitybase/cdn": "^5.4.26",
"@unitybase/ub": "^5.5.11",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubs": "^5.4.14",
"@unitybase/ubs": "^5.4.15",
"lodash": "^4"
},
"devDependencies": {
......
......@@ -6,8 +6,6 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
## [Unreleased]
### Added
- `ub-pub` now exports a `CryptoJS` instance (included modules are enc-base64, sha256, md5)
- `enc-base64` module added to CryptoJS instance. Available as `UB.CryptoJS.enc.Base64`.
### Changed
......@@ -15,6 +13,13 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Removed
### Fixed
## [5.5.18] - 2020-07-29
### Added
- `ub-pub` now exports a `CryptoJS` instance (included modules are enc-base64, sha256, md5)
- `enc-base64` module added to CryptoJS instance. Available as `UB.CryptoJS.enc.Base64`.
### Fixed
- allows to encode a non-english passwords for UBLDAP auth by using `base64` from CryptoJS instead of `btoa` in AsyncConnection.
This fix error "String contains an invalid character" in case password contains non-english letters. From a server side
......
{
"name": "@unitybase/ub-pub",
"version": "5.5.17",
"version": "5.5.18",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ub-pub",
"version": "5.5.17",
"version": "5.5.18",
"description": "Data layer for accessing UnityBase server from Browser or NodeJS",
"main": "./ub-pub.js",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ub-pub",
......
{
"name": "@unitybase/ubdev",
"version": "0.0.115",
"version": "0.0.116",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubdev",
"version": "0.0.115",
"version": "0.0.116",
"description": "UnityBase developer tools",
"main": "ubdev.js",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubdev",
......@@ -22,8 +22,8 @@
"dependencies": {
"@unitybase/codemirror-full": "^1.2.30",
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ubm": "^5.4.7"
"@unitybase/ub-pub": "^5.5.18",
"@unitybase/ubm": "^5.4.8"
},
"keywords": [
"UnityBase",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.4.8] - 2020-07-29
## [5.4.7] - 2020-07-28
## [5.4.6] - 2020-07-26
## [5.4.5] - 2020-07-19
......
{
"name": "@unitybase/ubm",
"version": "5.4.7",
"version": "5.4.8",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubm",
"version": "5.4.7",
"version": "5.4.8",
"description": "Set of entities for constructing a dynamically generated UnityBase UI. Enumerations, navigation desktops & shortcuts, forms, ER diagrams",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubm",
"config": {
......@@ -22,7 +22,7 @@
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/ub": "^5.5.11",
"@unitybase/uba": "^5.4.24",
"@unitybase/ubs": "^5.4.14"
"@unitybase/ubs": "^5.4.15"
},
"devDependencies": {
"@unitybase/stubs": "^5.1.1",
......
......@@ -15,6 +15,7 @@ and this project adheres to [Semantic Versioning](http://semver.org/).
### Fixed
## [5.4.15] - 2020-07-29
## [5.4.14] - 2020-07-28
## [5.4.13] - 2020-07-26
## [5.4.12] - 2020-07-19
......
{
"name": "@unitybase/ubs",
"version": "5.4.14",
"version": "5.4.15",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "@unitybase/ubs",
"version": "5.4.14",
"version": "5.4.15",
"description": "Reports, User messages (notifications), Settings (aka about:config), Counters",
"repository": "https://git-pub.intecracy.com/unitybase/ubjs/tree/master/packages/ubs",
"config": {
......@@ -30,7 +30,7 @@
"@unitybase/cs-shared": "^5.5.1",
"@unitybase/pdf": "^5.0.31",
"@unitybase/ub": "^5.5.11",
"@unitybase/ub-pub": "^5.5.17",
"@unitybase/ub-pub": "^5.5.18",
"@unitybase/uba": "^5.4.24",
"@unitybase/xlsx": "^5.1.33",
"mime-types": "^2.1.14",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment